Паскаль составить программу Найти сумму ряда с точностью =10-3 , общий член которого an...

0 голосов
111 просмотров

Паскаль составить программу Найти сумму ряда с точностью =10-3 , общий член которого an = ((3^n)*n! )/ (2n)!


Информатика (15 баллов) | 111 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Паскаль АВС

Program LoctarUgar;
uses crt;
const
  eps=0.001;

function fact(n : integer) : longint;
  begin
    if n <= 1<br>         then  fact := 1
         else   fact := n * fact(n - 1);
  end;

var
  t,s:real;
  i:integer;
begin
  writeln('*** Alphaeus is thinking... ***');
  writeln('***          OK             ***');
  writeln();
  writeln('Программа вычисляет частичную сумму ряда с заданной точностью');
  writeln('  Общий член ряда:  an = ((3^n)*n! )/ (2n)!');
  writeln('Вычисление прекратится, когда модуль очередного слагаемого станет меньше 0,001');
  writeln();
  s:=0;   i:=1;   t:=1;
  while t>eps do
    begin
      t:=(power(3,i)*fact(i))/(2*fact(2*i));
      s:=s+t;
      writeln('a(',i,')=',t:0:6,'  S=',s:0:6);
      i:=i+1;
     end;
  writeln();
  writeln('Сумма ряда равна',s:0:6);
end.



(52.6k баллов)
0

спасибо большое

0

:)

0

while t>eps do
begin
t:=(power(3,i)*fact(i))/(2*fact(2*i));
s:=s+t;
writeln('a(',i,')=',t:0:6,' S=',s:0:6);
i:=i+1;

0

тьфу блин...кароче дебаг указывает туда где power сразу после скобки. пишет unknown identifier (( хотя вроде все объявлено

0

power - это возведение в степень. У меня Паскаль АВС 3.0. У тебя наверное, другая версия Паскаля. Посмотри в нете, как задать степень в твоей версии (там нужно 3 в степени i)

0

спасиб, решил проблему