Найти средний рост 32 учеников . Нужно написать программу!

0 голосов
31 просмотров

Найти средний рост 32 учеников .
Нужно написать программу!


Информатика (200 баллов) | 31 просмотров
0

На каком языке?

0

Паскаль

Дано ответов: 2
0 голосов
Правильный ответ

Var
  i, n, s: integer;

begin
  s := 0;
  Writeln('Введите через пробел 32 значения роста в см');
  for i := 1 to 32 do
  begin
    Read(n);
    s := s + n
  end;
  Write('Средний рост равен ', s / 32:0:1, ' см')
end.

Тестовое решение:

Введите через пробел 32 значения роста в см
157 153 169 169 157 162 160 159 152 159 152 166 159 167 164 153 170 155 170 170 161 155 151 153 161 159 170 166 160 159 161 152
Средний рост равен 160.3 см


(142k баллов)
0 голосов

Var
mas:array[1..32] of real;
i,k:integer;
sum:real;
begin
for i:= 1 to 32  do 
begin write('Введите рост ',i,' ученика'); readln(mas[i]) end;
writeln;
sum:=0;
k:=0;
for i:= 1 to 32 do 
begin sum:=sum+mas[i]; k:=k+1 end;
write(sum/k)
end.

(1.3k баллов)
0

Хех... хорошо, чтобы Вам когда-нибудь в жизни пришлось ввести несколько сотен чисел и перед каждым выскакивало предложение ввести очередное)))

0

да ваша программа эффективнее по времени и по памяти. потому что вы данные сразу обрабатываете, а я их в массив ложу. да и зачем я переменную k вводит, если и так известно количество.