Помогите решить в паскале1) Составить программу для того, чтобы компьютер, используя...

0 голосов
37 просмотров

Помогите решить в паскале
1) Составить программу для того, чтобы компьютер, используя генератор случайных чисел, записал на экране случайное число, значение которого лежит в пределах от 5 до 6.
2) Введено 3-значное число. Вывести число в зеркальном отображении.
3)Введенное 4-значное число изменить так, чтобы 1-3 и 2-4 цифры поменялись местами.


Информатика (37 баллов) | 37 просмотров
Дан 1 ответ
0 голосов

Program task1;
var  a :integer;
begin
  randomize;  a:= 0;  while (a <> 5) and (a <> 6) do    a:= random(7);  writeln(a);
end.

program task2;
var  Digit, i :integer;  DigitStr :string;
begin
  readln(Digit);  str(Digit,DigitStr);  for i:= length(DigitStr) downto 1 do    write(DigitStr[i]);
end.

program task3;
var  Digit :integer;  NewDigit, DigitStr :string;
begin
  readln(Digit);  str(Digit,DigitStr);  NewDigit:= DigitStr[3] + DigitStr[4] + DigitStr[1] + DigitStr[2];  writeln(NewDigit);
end.

(2.0k баллов)