Помогите написать программу ** паскале!!Создать файл а4, состоящий из 28 целых чисел....

0 голосов
20 просмотров

Помогите написать программу на паскале!!
Создать файл а4, состоящий из 28 целых чисел. Найти среднее арифметическое всех чисел.


Информатика (12 баллов) | 20 просмотров
Дан 1 ответ
0 голосов

Program abc;
var f: text; { Если не будет работать, то написать вместо "text" "file of longint" или еще что-нибудь другое.}
  x, y: longint;
  i: byte;
begin
  y := 0;

  assign(f, 'a4');
  reset(f);

  for i := 1 to 28 do
  begin
    read(f, x);
    y := y + x;
  end;

  writeln(y / 28);
  close(f);
end.

(344 баллов)