Помогите написать программу ** C# Написать программу, удаляющую из записи числа все...

0 голосов
39 просмотров

Помогите написать программу на C#
Написать программу, удаляющую из записи числа все чётные цифры.


Информатика (46 баллов) | 39 просмотров
Дан 1 ответ
0 голосов

Static class Program
{
    public static IEnumerable Digits(this uint X, bool Reverse = true)
    {
        do { yield return X % 10; } while ((X /= 10) != 0);
    }


    static uint ToUnsignedInt32(this IEnumerable Digits)
    {
        return Digits.Reverse().Aggregate((a, d) => a * 10 + d);
    }


    static void Main()
    {
        Console.WriteLine(
            uint.Parse(Console.ReadLine())
                .Digits()
                .Where(d => d % 2 == 1)
                .ToUnsignedInt32());
                
        Console.ReadKey();
    }
}

(3.8k баллов)