Написать программу, которая вычисляет А в степени N.

0 голосов
52 просмотров

Написать программу, которая вычисляет А в степени N.


Информатика (91 баллов) | 52 просмотров
0

Какого типа a? Целое, вещественное?

0

не знаю, если честнов задании написано так, как я тут написала

Дано ответов: 2
0 голосов

Program z3;
var a, N, i: integer;
temp: int64;
begin       
readln(a, N);       
temp:=a;       
for i:=1 to N-1 do begin               
temp:=temp*a;       
end;       
write(temp);
end.

(915 баллов)
0 голосов

#include
int main()
{
    int a, n, answer = 1;
    scanf("%d %d", &a, &n);
    for(int i = 0;i     {
        answer *= a;
    }
    printf("%d", answer);
}

(92 баллов)