Напишите программу определения простого числа в Паскале

0 голосов
37 просмотров

Напишите программу определения простого числа в Паскале


Информатика (62 баллов) | 37 просмотров
0

ну так как реализует?

0

в коде паскаль

0

пожалуйста

0

Умоляю

0

у меня экзамен завтра , а меня не было когда она говорила всем

0

я же все сделал

0

если сам алгоритм подсказали , то где проблема .

Дано ответов: 2
0 голосов
Правильный ответ

Var
  i,n,m,s:integer;
begin
  write('Введите число: ');
  readln(n);
  if n mod 2=0 then
    writeln('Число не является простым')
  else begin
    m:=trunc(sqrt(n));
    i:=3;
    while (n mod i <> 0) and (i<=m) do i:=i+2;<br>    if i<=m then writeln('Число не является простым')<br>    else writeln('Число является простым')
  end
end.

(142k баллов)
0

m:=trunc(sqrt(n)); Что это?

0 голосов

Program chisla;
uses crt;
var i,a,k: integer;
begin
clrscr;
write('введите число: ');
readln(a);
k:=0;
for i:=2 to a div 2 do
if a mod i =0 then k:=k+1;
if k=0 then write('простое')
else writeln('не простое');
readln;
end.

(456 баллов)
0

ну да вещь простенькое

0

но рабочее