ПОЖАЛУЙСТА, ПОМОГИТЕ!!!Ниже записана программа. Получив ** вход число x, эта программа...

0 голосов
32 просмотров

ПОЖАЛУЙСТА, ПОМОГИТЕ!!!
Ниже записана программа. Получив на вход число x, эта программа печатает два числа, L и M. Укажите наименьшее из таких чисел x, при вводе которых алгоритм печатает сначала 3, а потом 28.
var x, L, M: integer;
begin
readln(x);
L:=0; M:=0;
while x > 0 do begin
L:=L+1;
if M < x then begin
M:= M + (x mod 10) * 2;
end;
x:= x div 10;
end;
writeln(L); write(M);
end.


Информатика (23 баллов) | 32 просмотров
Дан 1 ответ
0 голосов

177: 3 цифры, M тоже = 28

(16.9k баллов)
0

Я ответ и сама знаю. Мне надо решение.

0

Какое решение? Не перебором же. Надо понять суть алгоритма (L - количество цифр, а M - удвоенная сумма цифр... Ну, с условием) и подобрать