Написать программу в паскалеНапишите программу, подсчитывающую количество различных букв...

0 голосов
18 просмотров

Написать программу в паскале

Напишите программу, подсчитывающую количество
различных букв в заданном слове.

Входные данные: ввести строкy Y с длиной не более 255 символов.

Выходные данные: вывести одно число, количество различных символов в
данной строке.


Информатика (12 баллов) | 18 просмотров
Дан 1 ответ
0 голосов
var
  y, b: string;
  i: integer;

begin
  readln(y);
  for i := 1 to length(y) do
    if (Pos(y[i], b) = 0) then
      b := concat(b, y[i]);
  writeln(length(b));
end.
(16.9k баллов)