Составьте программу,которая проверяет,является ли человек заданного возраста...

0 голосов
66 просмотров

Составьте программу,которая проверяет,является ли человек заданного возраста школьником,если возраст школьника-от 6 о 17 лет,и выводит на экран соответствующее сообщение "Равны"либо "Неравны"


Информатика (37 баллов) | 66 просмотров
Дан 1 ответ
0 голосов
var
  a: byte; //Возраст явно не больше 255 лет и не меньше 0 :)

begin
  readln(a);
  case (a) of
    6..17:
      writeln('Равны');
    else
      writeln('Не равны');
  end;
end.

Но если нужно через if..then..else:

var
  a: byte; //Возраст явно не больше 255 лет и не меньше 0 :)

begin
  readln(a);
  if ((a >= 6) and (a <= 17)) then<br>      writeln('Равны')
  else
      writeln('Не равны');
end.
(16.9k баллов)
0

что такое CASE(A)of????

0

оператор выбора, лаконичнее... Если хотите, заменю на if..then..else

0

а крнтурну карту по географ сможешь сделать?

0

"Смогу ли я? Да. Стану ли за это браться? Нет." -Техник учёных о чёрном ящике