1. Написать программу, решающую уравнение ax=b. Предусмотреть все варианты для значений a...

0 голосов
37 просмотров

1. Написать программу, решающую уравнение ax=b. Предусмотреть все варианты для значений a и b.

2. Идет к-ая секунда суток. Определить, сколько целых часов и целых минут прошло с начала суток. На экран вывести фразу: «It is … hours … minutes».

3. Вводится пятизначное число. Найти сумму цифр этого числа.

Написать программы в паскале.


Информатика (80 баллов) | 37 просмотров
Дан 1 ответ
0 голосов

1.

 

program simple;

var a,b:integer;

begin

 writeln('daite a, b); readln(a,b);

 writeln('x = ', b/a); readln;

end;

 

2.

 

program day;

var h,hours,minutes:longint;

begin

  writeln('daite secundi'); readln(h);

  hour:= h div 3600; minutes:=h mod 36000;

  if (minutes > 60) or (minutes=60) then 

   begin

     hour:=hour+1;

     minutes:=minutes-60;

  end;

  writeln('It is 'hours' hours 'minutes' minutes');

readln;

end;

 

3.

 

program summaChisla;

var s:string; i,sum: longint; c,cod:integer;

begin

  writeln('daite nomer); readln(s);

  for i:=1 to length(s) do

   begin

      val(s[i],c,cod); sum:=sum+c;

   end;

writeln('summa :',sum); readln;

end;

(196 баллов)