Написать программу ** turbo pascal.1.Вычислить значение факториала n!...

0 голосов
27 просмотров

Написать программу на turbo pascal.
1.Вычислить значение факториала n! (P=1*2*...*n*N)..N=12
2.Найти сумму элементов заданного массива C[1..n]. Данные для ввода: n=7; C[1;2;3;-4;5;-6;7].
3.


image

Информатика (20 баллов) | 27 просмотров
Дано ответов: 2
0 голосов
Правильный ответ
var
  y, n, i: integer;

begin
  n := 12;
  y := 1;
  i := 1;
  repeat
    y *= i; 
    i += 1;
  until i > n;
  writeln(y);
end.
------------------------------
var
  y, n, i: Integer;
  c: array of integer;
begin
  readln(n);
  setlength(c, n);
  for i := 1 to n do
  begin
    write('c[', i, '] => ');
    readln(c[i - 1]);
    y := y + c[i - 1];
  end;
  writeln(#13, y);
end.
----------------------------------
const
  a = 20.3;
var
  f, x: real;
begin
  readln(x);
  if (x > 1) then
    f := ln(x + 1)
  else
    f := sqr(cos(sqrt(abs(a * x))));
  writeln(f);
end.
(16.9k баллов)
0 голосов

1)
const
n=12;
var
i,p:integer;
begin
p:=1;     
for i:=1 to n do         
    p:=p*i;     
writeln(P);
end.
2)
const
n=7;
varc:array[1..7]of integer;
i,s:integer;
begin
for i:=1 to n do
    begin   
       readln(c[i]);   
       s:=s+c[i];
    end;
writeln(s)
end.
3)
const
a=20.3;
var
x,y:real;
begin
readln(x);
    if x>1 then   y:=ln(x+1)
     else    y:=sqr(cos(sqrt(abs(a*x)))); 
  writeln(y);
end.

(9.6k баллов)