Написать программу, которая вводит целые числа и складывает их, пока не будет введено...

0 голосов
97 просмотров

Написать программу, которая вводит целые числа и складывает их, пока не будет введено число 0. вывести сумму чисел , введённых до 0.


Информатика (27 баллов) | 97 просмотров
Дан 1 ответ
0 голосов
Правильный ответ
var
  sum, num: integer;

begin
  repeat
    readln(num);
    if (num = 0) then
      break;
    write(sum, ' + ', num, ' = ');
    sum := sum + num;
    writeln(sum);
  until (false);
end.
(16.9k баллов)
0

А как будет выглядеть эта программа в С++

0

#include
using namespace std;

int main() {
int sum = 0,
num = 0;
while (1)
{
cin >> num;
if (num == 0) break;
cout << sum << " + " << num << " = ";<br> sum = sum + num;
cout << sum << endl;<br> }

return 0;
}