Помогите написать программу в паскале. Задание:** плоскости даны 2 точки А (х1; у2) и В...

0 голосов
31 просмотров

Помогите написать программу в паскале. Задание:На плоскости даны 2 точки А (х1; у2) и В (х2; у2), определить какая из них находится дальше от начала координат. Я поняла, что нужно найти их длины (формулы я знаю), а правильно написать программу не могу


Информатика (12 баллов) | 31 просмотров
Дан 1 ответ
0 голосов

program prog;
var x1,x2,y1,y2,i,b:integer;
begin;
writeln('Введите 4 точки: x1, y1; x2, y2');
readln(x1,y1,x2,y2);
i:=abs(x1+y1);
b:=abs(x2+y2);
if i=b then writeln('Координаты находятся на одной точке') else begin
if i>b then writeln('Первая координата дальше') else writeln('Вторая координата дальше');
end;
end.

(48 баллов)