Напишите программу для решения следующей задачи: Даны натуральные числа m, n. Получить...

0 голосов
43 просмотров
Напишите
программу для решения следующей задачи: Даны
натуральные числа m, n.
Получить все кратные им числа, меньшие m*n. Сделать прошу в Pascal

Информатика (191 баллов) | 43 просмотров
Дан 1 ответ
0 голосов

Program pr1;
var i,m,n:integer;
begin
readln(m);
readln(n);
for i:=1 to m*n-1 do begin
if (i mod n = 0) and (i mod m = 0)
then
writeln(i)
end
end.

(735 баллов)