ПОМОГИТЕ написать программу для суммирования четных элементов ** нечетных позициях в...

0 голосов
74 просмотров

ПОМОГИТЕ написать программу для суммирования четных элементов на нечетных позициях в одноименном массиве


Информатика (61 баллов) | 74 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Const
  n = 30;

var
  a: array[1..n] of integer;
  i, s: integer;

begin
  Randomize;
  Writeln('Исходный массив');
  s := 0;
  for i := 1 to n do
  begin
    a[i] := Random(101) - 50;
    Write(a[i], ' ');
    if ((i mod 2) = 1) and ((a[i] mod 2) = 0) then s := s + a[i]
  end;
  Writeln(#13#10, 'Сумма найденных элементов ', s)
end.

Тестовое решение:
Исходный массив
49 -39 -17 6 24 38 20 50 6 -36 -4 -7 -31 41 -8 20 32 49 -48 -47 50 48 -41 -44 -26 -11 9 38 -24 -34
Сумма найденных элементов 22


(142k баллов)