Написать программу ** Free Pascal которая переводит число из десятичной системы в двоичную

0 голосов
36 просмотров

Написать программу на Free Pascal которая переводит число из десятичной системы в двоичную


Информатика (223 баллов) | 36 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Function ToBinaryString(x: integer): string;
var r, s: string;
begin
  if x < 0 then begin
    s := '-';
    x := -x;
  end;
  while x <> 0 do begin
    r := Chr((x and 1) or 48) + r;
    x := x shr 1;
  end;

  ToBinaryString := s + r;
end;

var x: integer;
begin
  readln(x);
  writeln(ToBinaryString(x));
end.

(3.8k баллов)