написать программу ** ПАСКАЛЕ: Дана матрица А, имеющая N строк и N столбцов. Сформируйте...

0 голосов
33 просмотров
написать программу на ПАСКАЛЕ: Дана матрица А, имеющая N строк и N столбцов. Сформируйте два одномерных массива. В один перешлите четные, а в другой -нечетные элементы матрицы. Выведите на экран все массивы.
ИЛИ
написать программу на ПАСКАЛЕ: Вычислить произведение n! до значения 1255534676756. Пожалуйста решите какую сможете.

Информатика (37 баллов) | 33 просмотров
0

а вторую знаешь? да для авс можно

Дан 1 ответ
0 голосов
Правильный ответ

Var
  i,f:int64;
begin
  f:=1;
  i:=1;
  while f<1255534676756 do<br>    begin
    f:=f*i;
    writeln(i:2,' ',f);
    i:=i+1
    end
end.

Результат работы программы:

 1 1
 2 2
 3 6
 4 24
 5 120
 6 720
 7 5040
 8 40320
 9 362880
10 3628800
11 39916800
12 479001600
13 6227020800
14 87178291200
15 1307674368000


(142k баллов)