Составить алгоритм решения задачи согласно своему варианту и написать программу ** языке...

0 голосов
187 просмотров

Составить алгоритм решения задачи согласно своему варианту и написать программу на языке С++. В отчете предоставить блок-схемы функции :

Задание

Вводится последовательность целых чисел, 0 – конец последовательности.Для каждого числа последовательности проверить, представляют ли его цифры строго возрастающую последовательность, например, 1234(результатом функции будет 1 – Да, 0 - НЕТ).


Информатика (339 баллов) | 187 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

#include
int main()
{
    int n;
    bool flag = true;
    std::cin >> n;
    while(n != 0) \\!Ожидаем появления на входе нуля
    {
        while (n >= 10) 
        {
            if(n / 10 % 10 >= n % 10) \\!Сравниваем две последние цифры в числе
                flag = false; \\!Если не совпадает с условием, flag = false, т.е. выведется 0
            n = n / 10;
        }
        std::cout << flag << std::endl;<br>        flag = true;
        std::cin >> n;
    }
}

(9.5k баллов)