Разработать алгоритм и составить программу ** выбранном языке программирования ( Паскаль...

0 голосов
51 просмотров
Разработать алгоритм и составить программу на выбранном языке программирования ( Паскаль или Qbasic) для нахождения произведения цифр числа, полученного при умножении числа 12 на свой порядковый номер в списке группы.

Информатика (147 баллов) | 51 просмотров
0

Можно подробней? Или этого ответа будет достаточно?

Дан 1 ответ
0 голосов
Правильный ответ

Var
  m, n, p: integer;

begin
  Write('Введите свой номер в группе: ');
  Readln(n);
  n := n * 12;
  p := 1;
  repeat
    m := n mod 10;
    p := p * m;
    n := n div 10
  until n = 0;
  Writeln('Результат ', p)
end.

Тестовое решение:

Введите свой номер в группе: 13
Результат 30


(142k баллов)