Помогите написать программу!!! PascalABC. Введите массив из 5 элементов с клавиатуры и...

0 голосов
435 просмотров

Помогите написать программу!!! PascalABC. Введите массив из 5 элементов с клавиатуры и найдите количество элементов, старшая цифра которых равна 8.


Информатика (114 баллов) | 435 просмотров
Дан 1 ответ
0 голосов

Var a: array [1..5] of integer; i, amount: integer;
begin
     read(a[1], a[2], a[3], a[4], a[5]);
     amount := 0;
     for i := 1 to 5 do
     begin
          while a[i] >= 10 do
          begin
               a[i] := a[i] div 10;
          end;
          if a[i] = 8
          then
              amount := amount + 1;
     end;
     writeln(amount);
end.

(9.5k баллов)