Написать программу вычисления n!

0 голосов
48 просмотров

Написать программу вычисления n!


Информатика (14 баллов) | 48 просмотров
Дано ответов: 2
0 голосов
programfactorial;  functionfact(n:integer):longint;beginif(n=0)thenfact:=1elsefact:=n*fact(n-1);  end;  varn:integer;  begin  forn:=0to16do  writeln(n,'! = ',fact(n));end.
(2.6k баллов)
0 голосов

var 

  n, fact: word;  //fact - факториал числа

  i: integer;

 

begin

  fact:= 1;  //Присваиваем начальное значение

  writeln('Введите число n');

  readln(n);

  for i:= 1 to n do   //Для i, равного от 1 до n умножаем значение fact на i

    fact:= fact * i;

  writeln(n, '! = ', fact);

end.

Отметь решение, как лучшее, плиз)

  

(2.1k баллов)