Составьте программу ** Pascal.Найти сумму ряда (скрин во вложении) двух функций (тоже во...

0 голосов
41 просмотров

Составьте программу на Pascal.Найти сумму ряда (скрин во вложении) двух функций (тоже во вложениях f1 и f2), при этом а=2.12 b=7.45 c=0.34


image
image

Информатика (166 баллов) | 41 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Const
  a: double = 2.12;
  b: double = 7.45;
  h: double = 0.34;

function Power(p, q: double): double;
{Возвращает значение p в степени q}
begin
  Power := exp(q * ln(p))
end;

var
  x, f1, f2, y, s: double;

begin
  x := a;
  s := 0;
  while x <= b do<br>  begin
    f1 := 3 * ln(Power(sin(x) + sqr(x), 1 / 5));
    f2 := (2 * x + 1) / Power(x, 5);
    y := f1 / f2;
    s := s + y;
    x := x + h
  end;
  Writeln('S=', s:0:5)
end.

Результат выполнения:

S=12897.41510


(142k баллов)