Паскаль АВС. Дана строка символов. Составьте программу которая подсчитывает, сколько в...

0 голосов
44 просмотров

Паскаль АВС. Дана строка символов. Составьте программу которая подсчитывает, сколько в данной строке слов оканчивающихся на а. Все слова разделяются 1 пробелом и только русские буквы.


Информатика (144 баллов) | 44 просмотров
0

ну, это не я ставила задачу, а учитель дал сделать по методичке Паскаль

0

Вы не понимаете, что учитель дал это Вам, а не нам. А нам задачу даете Вы и должны ставить её корректно.

0

хорошо, я поняла

0

Вы даже не написали какой именно Паскаль - Турбо, Borland, Object, Free, ABC, ABC.NET и т.п.

0

А все эти "паскали" разные

0

паскаль авс

0

Тогда осталось поправить текст задания для конкретизации

0

окай

0

Видите, все просто теперь)

0

спасибо больше!

Дан 1 ответ
0 голосов
Правильный ответ

Var
  s: string;
  i, n: integer;
  a: set of char;

begin
  Writeln('Введите строку текста');
  Readln(s);
  n := 0;
  a := ['А', 'а'];
  for i := 1 to Length(s) do
    if (s[i] = ' ') and (s[i - 1] in a) then n := n + 1;
  if (s[i - 1] in a) then n := n + 1;
  Writeln('Количество слов, оканчивающихся буквой "а", равно ', n)
end.

Тестовое решение:
Введите строку текста
А роза упала на лапу Азора
Количество слов, оканчивающихся буквой "а", равно 4


(142k баллов)