Очень срочно!!!!! 1. Написать программу, в которой пользователь задает три стороны...

0 голосов
46 просмотров

Очень срочно!!!!!
1. Написать программу, в которой пользователь задает три стороны треугольника и которая выводит слово true, если треугольник равносторонний, и false, если не равносторонний.
2. Написать программу, в которой пользователь задает три стороны треугольника и которая выводит слово true, если треугольник равнобедренный, и false, если не равнобедренный.


Информатика (252 баллов) | 46 просмотров
Дан 1 ответ
0 голосов

1)
var
a,b,c: integer;
begin
read(a,b,c);
if (a=b) and(b=c) then
  writeln('true')
else writeln('false');
end.
2)
var
a,b,c: integer;
begin
read(a,b,c);
if (a=b) or (a=c) or (b=c) then
writeln('true')
else writeln('false');
end.

(627 баллов)
0

для лучшего ответа нужно решение нескольких человек

0

а, ясно)

0

Кстати, не integer, а boolean))) Но всё равно спасибо;-)

0

Нет, у меня все правильно, вы ошибаетесь. Тип boolean может принимать только 2 значения true и false.А здесь a,b,c - числа.

0

Что ж, признаю ошибку