Напишите программу в PascalAbc которая ** вход получает 3 вещественных числа и выводит **...

0 голосов
47 просмотров

Напишите программу в PascalAbc которая на вход получает 3 вещественных числа и выводит на экран большее из них.


Информатика (12 баллов) | 47 просмотров
Дан 1 ответ
0 голосов

Var 
x,y,z:real;
begin
writeln('Введите три числа');
read(x,y,z);
If (x>z) and (x>y) then
writeln('Наибольшее= ',x);
If (y>z) and (y>x) then
writeln('Наибольшее= ',y);
If (z>x) and (z>y) then
writeln('Наибольшее= ',z);
If (z=y) and (y=x) then writeln('Все числа одинаковые') else
begin
If (z=x)  then writeln('числа x и z равны');
If (y=x)  then writeln('числа x и y равны');
If (z=y)  then writeln('числа y и z равны');
end;
end.

(1.4k баллов)