Помогите пожалуйста написать программу ** C++. Условие такого: Вычислить сумму ряда,...

0 голосов
33 просмотров

Помогите пожалуйста написать программу на C++.
Условие такого: Вычислить сумму ряда, 1-1/2+1/3-1/4...1/n.
По введенному n нужно посчитать сумму.


Информатика (205 баллов) | 33 просмотров
0

Если не ошибаюсь, эта задача с mccme?

Дан 1 ответ
0 голосов

#include
using namespace std;
int main()
{   
int n, i, m = 1;   
double s = 0.0;   
cin>>n;   
for (i = 1; i <= n; s += double(m)/i, m = -m, i++);    <br>cout<<s;<br>}

(1.0k баллов)
0

большое спасибо)