Напишите программу, которая сначала считывает целое положительное число, а затем печатает...

0 голосов
92 просмотров

Напишите программу, которая сначала считывает целое положительное число, а затем печатает значение меньшей из его первой и последней цифр. Исходное число не превышает 30 000. Программа должна напечатать только число, равное значению меньшей из его первой и последней цифр. Если число состоит из одной цифры, то минимальным является значение самой этой цифры.
Примеры работы программы:
Ввод: 3; Вывод:3
Ввод: 2194; Вывод: 2


Информатика (12 баллов) | 92 просмотров
Дан 1 ответ
0 голосов

Var a,af,al:integer;
begin
  writeln('Введите число');
  readln(a);
  if a<10 then writeln('Ответ: ',a)<br>  else
  if a<=99 then<br>  begin
  af:=a div 10;
  al:=a mod 10;
  if af>al then writeln('Ответ: ',al) else writeln('Ответ: ',af)
  end
  else
  if a<=999 then <br>  begin
  af:=a div 100;
  al:=a mod 10;
  if af>al then writeln('Ответ: ',al) else writeln('Ответ: ',af)
  end
  else
  if a<=9999 then <br>  begin
  af:=a div 1000;
  al:=a mod 10;
  if af>al then writeln('Ответ: ',al) else writeln('Ответ: ',af)
  end
  else
  if a<=30000 then <br>  begin
  af:=a div 10000;
  al:=a mod 10;
  if af>al then writeln('Ответ: ',al) else writeln('Ответ: ',af)
  end;
end.

(884 баллов)