PascalABC 1. Напишите программу, которая работает с двумя целыми числами, введёнными с...

0 голосов
48 просмотров

PascalABC 1. Напишите программу, которая работает с двумя целыми числами, введёнными с клавиатуры. Программа выводит все чётные числа, расположенные в интервале между двумя введёнными числами. Например, пользователь вводит числа 10 и 20, программа выводит «12 14 16 18», если -8 и -3, то «-6 –4». Если пользователь вводит, например, числа 6 и 8, программа ничего не выводит. Точно так же программа ничего не выводит, если введённые числа равны, или второе указанное число меньше первого.


Информатика (188 баллов) | 48 просмотров
Дан 1 ответ
0 голосов

Var  
 a,b,i : integer;    
 begin 
  readln (a,b); 
   for i := (a+1) to (b-1) do 
   if i mod 2 = 0 then 
     writeln (i); 
end.

вроде работает pascalABC.Net

(2.6k баллов)
0

СПАСИБО