Помогите пожалуйста!!!! Не могу написать программу ** языке паскаль. Даны три целых...

0 голосов
75 просмотров

Помогите пожалуйста!!!! Не могу написать программу на языке паскаль. Даны три целых двузначных числа. Из наибольшего из них вычесть наименьшее и сравнить результат с оставшимся числом. Если полученное число будет больше вывести YES в противном случае NO.


Информатика (22 баллов) | 75 просмотров
0

а 3 число к чему? или с 3 числом сравнивать?

Дан 1 ответ
0 голосов
Правильный ответ

Var
  a,b,c,max,mid,min,t:integer;
begin
  Writeln('Введите через пробел три целых двухзначных числа');
  Readln(a,b,c);
  if a>b then begin max:=a; min:=b end
  else begin max:=b; min:=a end;
  if max  else mid:=c;
  if min>mid then begin t:=mid; mid:=min; min:=t end;
  if (max-min)>mid then Writeln('YES')
  else Writeln('NO')
end.

Тестовое решение:
Введите через пробел три целых двухзначных числа
37 93 74
NO



(142k баллов)
0

Спасибо огромное= )

0

Кнопочки и восторга на 4 из 5 звездочек вполне достаточно.