Нужно составить программу(ну как всегда Var////Began//// ну и т.д.) Дана дробь a/b....

0 голосов
25 просмотров

Нужно составить программу(ну как всегда Var////Began//// ну и т.д.) Дана дробь a/b. Требуется ее сократить. То есть записать это же число в виде c/d, где c — целое число, d — натуральное число и d минимальное возможное.


Информатика (90 баллов) | 25 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

var i,a,b,a1:integer;
begin
readln(a,b);
a1:=a;
for i:=1 to a1 do begin
if (a mod i=0) and (b mod i=0) then begin
a:=a div i;
b:=b div i;
end;
end;
writeln('c=',a,' d=',b);
end.

(9.9k баллов)