Напишите программу в fre pascale по данной задаче и данной блок схеме

0 голосов
55 просмотров

Напишите программу в fre pascale по данной задаче и данной блок схеме


image
image

Информатика (1.5k баллов) | 55 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Var i, j, sum, max, number_of_line: integer; a: array [1..10, 1..10] of integer;
begin
     randomize;
     max := 0;
     number_of_line := 1;
     for i := 1 to 10 do
         for j := 1 to 10 do
         begin
              a[i, j] := random(1000); {Для удобства проверки работоспособности массив заполняется рандомно}
              if max < a[i, j]
              then
                  begin
                       max := a[i, j];
                       number_of_line := i;
                  end;
         end;
     for i := 1 to 10 do
     begin
          for j := 1 to 10 do
              write(a[i, j], ' '); {Для проверки организован вывод всей матрицы}
          writeln;
     end;
     sum := 0;
     for j := 1 to 10 do
         sum := sum + a[number_of_line, j]; {Собственно, сам подсчёт суммы}
     writeln(sum);
end.
-------------------------------
Блок-схема не полностью видна, но программа будет очень похожа на вышенаписанную

(9.5k баллов)