1.Нужно составить программу перевода градусов в интервале 15-30 шкалы Цельсия ** градусы...

0 голосов
70 просмотров

1.Нужно составить программу перевода градусов в интервале 15-30 шкалы Цельсия на градусы Фаренгейта.

Формула преобразования F=C*1.8+32, здесь С – градусы Цельсия; F – градусы Фаренгейта.

2. Набирается последовательность слов, в конце которой нажимается клавиша Enter. Нужно написать программу, которая подсчитывает количество введённых символов и сколько раз встречается буква Т в тексте.

9 класс. язык програмирования ПАСКАЛЬ


Информатика (388 баллов) | 70 просмотров
Дан 1 ответ
0 голосов

Program Pr1;
uses crt;
var f,c:real;
begin
clrscr;
c:=15;
while c<=30 do begin<br> f:=c*1.8+32;
writeln(c,'-Цельсия; Фаренгейт - ',f);
c:=c+1;
end;
end.

2)

Program Pr1;
uses crt;
var stroka:string;
i,v,x:integer;
Begin
clrscr;
readln(stroka);
x:=0;
v:=0;
for i:=1 to length(stroka) do begin
if stroka[i]<>' ' then v:=v+1;
if (stroka[i]='т') or (stroka[i]='Т') then x:=x+1;
end;
writeln('Количество букв- ',v,' Количество букв Т -',x);
end.

(895 баллов)