Помогите пожалуйста написать программу ** паскале!!! Даны целые числа н (н>0),...

0 голосов
32 просмотров

Помогите пожалуйста написать программу на паскале!!!
Даны целые числа н (н>0), a1,....,aн. Все члены последовательности a1,....,aн, предшествующие первому по порядку наименьшему члену домножить на этот наименьший член.


Информатика (20 баллов) | 32 просмотров
0

т.е. найти меньший член из массива и домножить все члены последовательности на него?

0

теперь понятно)а то написано как то замудренно

0

если честно, я сам не понял задания

0

До меньшего

0

Да да

0

получается что не все члены будут умножаться на этот наименьший? или как?

0

жди

0

окейй

0

получается домножить все члены на этот наименьший до самого наименьшего

0

Я понял уже

Дан 1 ответ
0 голосов
Правильный ответ

Var n,a,b,i,min:integer;
mass:array[1..100000] of integer;
begin
writeln('Введите кол-во элементов массива');
read(n);
writeln('Введите числа');
for i:=1 to n do// задаем массив пока i не станет равно n (i:=i+1 )
read(mass[i]);//считываем массив с индексом i
min:=mass[1];// обозначаем первый элемент массива за первый
b:=1;// индекс от первого элемента массива
for i:=1 to n do//цикл задаем массив пока i не станет равно n (i:=i+1 )
if mass[i]b:=i;// обозначаем индекс
min:=mass[i];// обозначаем новый минимальный массив
end;
for i:=1 to b-1 do// задаем массив пока i не станет равно b-1 (i:=i+1 ); и еще b-1 значит чтобы само число b не входило в цикл
mass[i]:=mass[i]*mass[b];// домножаем на меньший массив
writeln('Полученный массив');// вывод массива
for i:=1 to n do
write(mass[i]:6);
end.

(1.7k баллов)
0

спасибо огромное тебе, выручил!!!

0

блин, мн блок схема нужна((

0

Я не успею кажись, девушка гулять гонит))0))0 давай просто подпишу тогда

0

Хотя давай

0

блок схему лень)

0

если не трудно

0

хотя не надо, напиши лучше блок схему плиз

0

если не сложно, можешь написать кратко, что в каждой строке происходит? Начиная с for i:= to n

0

как сможешь черкани на листке блок схему, пожалуйста