Напишите программу,которая содержит описание типов данных и подпрограмм для обработки...

0 голосов
49 просмотров

Напишите программу,которая содержит описание типов данных и подпрограмм для обработки одномерногго массива размерностью n , где n<=15.Программа должна состоять из подпрограмм:</p>

a)Ввод элементов массива с клавиатуры

b)Функции возвращающей сумму четных элементов массива

c)Функции выводящей на экран минимальный элемент массива


Информатика (300 баллов) | 49 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Комментарии:

Вот описание своего типа данных:

type
pArray = array [1..15] of integer;

 

Вот проверка на правильно введенноее значение от 1 до 15:

while (N<1) or (n>15) do, если введешь неправильно спросит еще раз

 

Подпрограммы:

 

 

Ввод элементов массива с клавиатуры здесь: procedure InputArray

Функции возвращающей сумму четных элементов массива: function SummOfEven

Функции выводящей на экран минимальный элемент массива: function MinimalElement




program ArrayProccessor;
uses crt;
type
pArray = array [1..15] of integer;

var myArray: pArray;
N:integer;

procedure InputArray(var arrayToInput:pArray; n:integer);
var i:integer;
begin
for i:=1 to n do
begin
write('vvedite a[',i,']=');
readln(arrayToInput[i]);
end;
end;

function SummOfEven(arrayToProcess:pArray; n:integer):integer;
var i:integer;
res:integer;
begin
res:=0;
for i:=1 to n do
begin
if not odd( arrayToProcess[i]) then res:=res+arrayToProcess[i];

end;
SummOfEven:=res;
end;

function MinimalElement(arrayToProcess: pArray; n:integer):integer;
var i:integer;
res:integer;
begin
res:= arrayToProcess[1];
for i:=2 to n do
begin
if(res>arrayToProcess[i]) then res:=arrayToProcess[i];
end;
MinimalElement:=res;
writeln('minimal element: ', res);
end;

begin
clrscr;
N:=0;
while (N<1) or (n>15) do
begin
write('Vvedite kol-vo elementov massiva ot 1 do 15: ');
readln(N);
end;
InputArray(myArray, n);
writeln('summa chetnih: ', SummOfEven(myArray, n));
MinimalElement(myArray, n);

readln;
end.

(1.8k баллов)