В классе 20 учеников писали диктант по русскому.Написать программу подсчета кол-ва 2 3 4...

0 голосов
205 просмотров

В классе 20 учеников писали диктант по русскому.Написать программу подсчета кол-ва 2 3 4 5 получивших за диктант(писать через массива)


Информатика (78 баллов) | 205 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

var

  a: array [1..20] of 2..5;  //Массив оценок учеников

  i: integer;

  n: array [2..5] of 2..5;  //Массив счетчиков оценок

 

begin

  for i:= 2 to 5 do   //Обнуляем счетчики оценок

    n[i]:= 0;

  for i:= 1 to 20 do   //Вводим оценки учеников и считаем их

  begin

    writeln('Введите оценку ', i, ' ученика');

    readln(a[i]);

    if a[i] = 2 then n[2]:= n[2] + 1;

    if a[i] = 3 then n[3]:= n[3] + 1;

    if a[i] = 4 then n[4]:= n[4] + 1;

    if a[i] = 5 then n[5]:= n[5] + 1;

  end;

  for i:= 2 to 5 do

    writeln('Количество получивших ', i, ' за диктант равно:  ', n[i]);  {Выводим значения счетчиков}

end.

   

(2.1k баллов)