Срочно!! Помогите написать программу в турбо паскале!!Огромное человеческое...

0 голосов
27 просмотров

Срочно!! Помогите написать программу в турбо паскале!!Огромное человеческое спасибо!!

Заполнить массив из 10 элементов случайными числами в интервалеот-50 до 50 и отсортировать его по убыванию с помощью алгоритма быстрой сортировки.


Информатика (76 баллов) | 27 просмотров
Дан 1 ответ
0 голосов

const low=1; high=10;

procedure qSort(var ar:array[low..high]of real; low,high:integer);
var i,j:integer;
m,wsp:real;
begin
i:=low;
j:=high;
m:=ar[(i+j) div 2];
repeat
while(ar[i] while(ar[j]>m) do j:=j-1;
if(i<=j) then begin<br> wsp:=ar[i];
ar[i]:=ar[j];
ar[j]:=wsp;
i:=i+1;
j:=j-1;
end;
until (i > j);
if(low if(iend;

var ar:array[low..high]of real;
i:integer;
begin
randomize;

for i:=low to high do ar[i]:=random(101)-50;
qSort(ar,low,high);
writeln;
for i:=low to high do write(ar[i],' ');
end.

(9.9k баллов)