1)составьте программу,которая заполняет массив a[1..10] случаынми целыми числами в...

0 голосов
24 просмотров

1)составьте программу,которая заполняет массив a[1..10] случаынми целыми числами в диапазоне от 0 до 10 и находит минимальный элемент массива среди элементов с нечётными индексами

2)составьте программу,которая заполняет массив a[1..10]случайными целыми числами в диапазоне от 0 до 10,находит максимальный элемент массива,а затем вычисляет,сколько раз он встречается в массиве


Информатика (133 баллов) | 24 просмотров
Дан 1 ответ
0 голосов

Первое.

var
a:array[0..9] of integer;
i,y,min:integer;
begin
randomize();
for i:=0 to 9 do
begin
y:= random(10);
a[i]:= y;
end;
for i:=0 to 9 do write(a[i],' ');
writeln(' - десять випадкових чисел');
min:=a[0];
for i:=1 to 9 do
if a[i] writeln(min, ' - мiнiмальне число.');

end.

Второе

var
a:array[0..9] of integer;
i,y,s,max:integer;
begin
randomize();
for i:=0 to 9 do
begin
y:= random(10);
a[i]:= y;
end;
for i:=0 to 9 do write(a[i],' ');
writeln(' - десять випадкових чисел');
max:=a[0];
for i:=1 to 9 do
if a[i] writeln(max, ' - максимальне число.');
s:=0; // сума чисел, що приймають таке значення
for i:=0 to 9 do
if a[i]=max then s:=s+1;
writeln('Зустричается ',s,' раз.');


end.



(34 баллов)