Написать программу, которая вычисляет сумму первых n целых положительных чисел. Кол-во...

0 голосов
56 просмотров

Написать программу, которая вычисляет сумму первых n целых положительных чисел. Кол-во суммируемых чисел должно вводиться во время работы программы. Ниже представлен рекомендуемый вид экрана во время работы программы :

Вычисление суммы четных положительных чисел.
Введите количество суммируемых чисел и нажмите
-> 12
Сумма первых 12 положительных четных чисел равна 156.


Информатика (14 баллов) | 56 просмотров
0

простите, а разве их сумма равна 156? я пересчитываю вручную, и все равно получается 78. может, я не так задание понимаю?

0

да, 156: 2+4+6+8+10+12+14+16+18+20+22+24=156

Дан 1 ответ
0 голосов

Program z1; var i, n, b: integer; begin writeln ('Введите любое целое число'); read (n); for i:=1 to n*2 do if i mod 2=0 then b:=b+i; writeln (b); end.

(1.5k баллов)
0

ааа... только без else

0

здесь не нужно else это упрощенная версия команды..

0

ну вот я и говорю) а вы написали.

0

точно.. сам себя перехитрил)) убери и все в порядке, хотя это не ошибка - программа выполняется и так))