Написать программу, которая по введенному значению аргумента вычисляет значение функции,...

0 голосов
144 просмотров

Написать программу, которая по введенному значению аргумента вычисляет значение функции, заданной в виде графика. Параметр R вводится с клавиатуры.


image

Информатика (182 баллов) | 144 просмотров
0

Вводиться целочисленный аргумент? Какой язык?

Дан 1 ответ
0 голосов

Var
r,y:real;
begin
      readln(r);
         if (r>=-7)and(r<=-3)then<br>                y:=r+7;
         if (r>=-3)and(r<=-2)then<br>                y:=4;
         if (r>=-2)and(r<=2)then<br>                y:=sqr(r);
         if (r>=2)and(r<=4)then<br>                y:=-2*r+8;
         writeln(y);
         if (r<-7)or(r>4)then
                writeln('Введите значение в диапазоне [-7;4]');
end.

(9.6k баллов)
0

точно. исправила

0

Спасибо, невнимательная

0

Огромное всем спасибо:) побольше бы таких добрых людей)

0

Крч, я немного подумал, ее же можно оптимизировать

0

var
r,y:real;
begin
readln(r);
y:=-1;
if (r<-7)or(r>4)then
writeln('Введите значение в диапазоне [-7;4]')
else if (r>=-7)and(r<=-3)then<br> y:=r+7
else
if (r>=-3)and(r<=-2)then<br> y:=4
else
if (r>=-2)and(r<=2)then<br> y:=sqr(r)
else
y:=-2*r+8;
if y>=0 then writeln(y);
end.

0

А если бы речь шла только о целых значениях можно было написать при помощи оператора выбора и было бы еще красивее.

0

Т.е лучше написать как во втором случае???

0

Я бы написала, как в первом. А говорю я вообще про другой оператор, который можно было бы использовать, если бы было известно, что переменные только целочисленные

0

Ну, в принципе, вторая побыстрее будет.

0

спасибо)