Напишите программу в turbo pascal: найти корни квадратного уравнения ax^2+bx+c

0 голосов
41 просмотров

Напишите программу в turbo pascal: найти корни квадратного уравнения ax^2+bx+c


Информатика (604 баллов) | 41 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Var a,b,c,d,x,x1,x2:real;
begin
readln(a.b.c);
d:=sqr(b) - 4*a*c;
if d<0 then<br>write('нет корней')
else 
If d=0 then begin
x:=-b/(2*a);
write(x); end
else begin
x1:=(-b+sqrt(d)/(2*a);
x2:=(-b-sqrt(d))/(2*a);
write(x1,x2);end;
readln
end.

(488 баллов)
0

Ты даже не представляешь, как ты меня выручил, я долго не мог нужный порядок действий составить, а по скольку я на домашнем обучении из за проблем со здоровьем, мне с утра позвонил учитель информатики, что бы проверить как я д/з сделал, я быстро открываю твой ответ, проговорил ей эту программу (ну еще я блок схему сделал тоже, но это не так важно) и у меня пятерочка все таки вышла! Спасибо тебе огромное, от души!!))