Напишите программу, которая вычисляет сумму: а) первых n натуральных чисел б) квадратов...

0 голосов
155 просмотров

Напишите программу, которая вычисляет сумму:
а) первых n натуральных чисел
б) квадратов первых n натуральных чисел
в) всех четных чисел в диапазоне от 1 до n
г) всех двухзначных чисел

Даю 20 баллов!!!


Информатика | 155 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Var
    i, s1, s2, s3, s4, n: integer;

begin
    write('n = ');
    readln(n);
    s1 := 0;
    s2 := 0;
    s3 := 0;
    s4 := 0;
    
    for i := 1 to n do
    begin
        s1 := s1 + i;
        s2 := s2 + sqr(i);
        if i mod 2 = 0 then s3 := s3 + i;
    end;
    
    for i := 10 to 99 do s4 := s4 + i;
    
    writeln('Сумма первых n натуральных чисел: ', s1);
    writeln('Сумма квадратов первых n натуральных чисел: ', s2);
    writeln('Сумма всех четных чисел: ', s3);
    writeln('Сумма всех двухзначных чисел: ', s4);
end.

(55.0k баллов)