Дан массив mas[1..10]: = 1,3,-1,4,0,-4,-4,3,0,-4. Укажите, чему будет равно k после...

0 голосов
70 просмотров

Дан массив mas[1..10]: = 1,3,-1,4,0,-4,-4,3,0,-4. Укажите, чему будет равно k после
выполнения алгоритма. В ответе укажите число.
k:= 1;
for i:= 9 downto 1 do
for j:=1 to i do
if mas[j] > mas[j+1] then begin
tmp:= mas[j];
mas[j]:= mas[j+1];
mas[j+1]:= tmp;
k:= k + 1;
end;
write('k = ', k);
readln


Информатика (49 баллов) | 70 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Это разновидность сортировки обменом - худший её вариант с точки зрения скорости и самый простой для написания: сортировка методом пузырька. Ручной подсчет значения k - количества сделанных в процессе сортировки обменов местами элементов массива, достаточно утомителен, поэтому проще добавить необходимые операторы и выполнить программу.
Ответ: k=28

(142k баллов)