Написать программу ** языке Паскаль. Даны три действительные числа. Сложить те из них,...

0 голосов
36 просмотров

Написать программу на языке Паскаль. Даны три действительные числа. Сложить те из них, значения которых не отрицательны.


Информатика (14 баллов) | 36 просмотров
Дан 1 ответ
0 голосов

Program chislo;
var a,b,c,d:integer;
begin
write('Введите a = ' );
readln(a);
if a>=0 then d:=d+a;
write('Введите b = ' );
readln(b);
if b>=0 then d:=d+b;
write('Введите c = ' );
readln(c);
if c>=0 then d:=d+c;
writeln(d);
write('Сумма положительных чисел равна ',d)
end.

(89 баллов)
0

program chislo;

var
a, b, c, d: real;

begin
readln(a, b, c);
if a >= 0 then d := d + a;
if b >= 0 then d := d + b;
if c >= 0 then
begin
d := d + c;
write(d);
end
else
if (a < 0) and (b < 0) and (c < 0) then
write('Ни одно из чисел не является положительным')
else
write(d);
end.