Задание 1. Нужно составить программу ** языке программирования (язык программирования и...

0 голосов
46 просмотров

Задание 1. Нужно составить программу на языке программирования (язык программирования и версию необходимо обязательно указать, иначе количество баллов за задачу будет равно 0)
Задача:
Календарь жителей планеты Мульти состоит из N месяцев, каждый месяц состоит ровно из 30 дней, неделя состоит из 7 дней. Особо несчастливыми на планете Мульти считается 13-е число месяца, если оно выпадает на пятницу.
Известно, что Новый год на планете Мульти начался в k-й по счету день недели (1-й день недели — понедельник, 2-й — вторник, 3-й — среда, … , 7-й — воскресенье). Определите, сколько в этом году на планете Мульти будет особо несчастливых пятниц, 13-е.
Программа получает на вход два натуральных числа, записанных в отдельных строках. Первое число — количество месяцев в календаре планеты Мульти N, не превосходящее 109. Второе число — номер дня недели, на который приходится первое число первого месяца нового года, может принимать значения от 1 до 7.
Программа должна вывести единственное натуральное число — количество несчастливых дней в этом году.
Пример входных и выходных данных
Ввод Вывод Примечание

12
1
2 2 На 13-е число будут приходиться пятницы четверого и одиннадцатого месяцев.


Информатика (740 баллов) | 46 просмотров
Дан 1 ответ
0 голосов

Язык программирования Pascal ABC
var n,k,i,j,d,c:integer;
label 1,2;
begin
1:writeln('Количество месяцев в календаре планеты Мульти:');
readln(n);
if (n>109)or(n<1) then<br>begin
writeln('Ошибка! Количество месяцев должно быть меньше или равно 109. Повторите ввод.');
goto 1;
end;
2:writeln('Номер дня на который приходится первое число первого месяца нового года:');
readln(k);
if (k>7)or(k<1) then<br>begin
writeln('Ошибка! Номер дня должен быть в диапозоне от 1 до 7. Повторите ввод.');
goto 2;
end;
d:=k;
for i:=1 to n do
begin
for j:=1+(k-1) to 30 do
begin
if (d=5)and(j=13) then c:=c+1;
d:=d+1;
if d>7 then d:=1;
end;
k:=1;
end;
writeln('Количество несчастливых дней в этом году: ',c);
end.

(884 баллов)