Напишите программу для решения следующей задачи. Ученики 4 класса вели дневники...

0 голосов
1.2k просмотров

Напишите программу для решения следующей задачи.
Ученики 4 класса вели дневники наблюдения за погодой и ежедневно записывали дневную температуру. Найдите среднюю температуру за время наблюдения. Если количество дней, когда температура поднималась выше нуля градусов, не менее 5, выведите YES, иначе выведите NO.
Программа получает на вход количество дней, в течение которых проводилось наблюдение N (1 ≤ N ≤ 31), затем для каждого дня вводится температура.


Информатика (15 баллов) | 1.2k просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Var N,i,k,z:integer;   
      s:real;
begin
s:=0;
k:=0; 
repeat 
    write('Введите кол-во дней : ');  
    readln(N); 
until (N>=1) and (N<=31); {проверка на верное количество дней}<br>for i:=1 to N do 
begin 
    write ('Введите значение температуры в ',i,' день : '); 
    readln(z); 
    s:=s+z; 
    if z>0 then k:=k+1; 
end;
s:=s/N;
writeln('Средняя температура = ',s);
if k>=5 then writeln('YES') else writeln('NO');
end.

(932 баллов)