Помогите с ИНФОЙ!!!ПЖЛСТ!Написать программу которая выводит квадраты и кубы 10 чисел...

0 голосов
43 просмотров

Помогите с ИНФОЙ!!!ПЖЛСТ!Написать программу которая выводит квадраты и кубы 10 чисел следующей последовательности:1,2,4,7,11,16...
(в программе чтоб присутствовала "for i:=1 to n do begin", забыл как такие программы называются=))


Информатика (69 баллов) | 43 просмотров
Дан 1 ответ
0 голосов
Правильный ответ

Это называется циклом. Вот программа и что получается на выводе.

var i, n: integer;
begin
n:=1;
for i:=1 to 10 do
begin
n:=n+i;
writeln(n:7, sqr(n):7, sqr(n)*n:7);
end;
end.


image
(4.7k баллов)