Написать программу перевода целого десятичного числа в двоичную систему диапозон значения...

0 голосов
39 просмотров

Написать программу перевода целого десятичного числа в двоичную систему диапозон значения до 1000. На языке Паскаль.


Информатика (12 баллов) | 39 просмотров
Дан 1 ответ
0 голосов

PascalABC.Net

var   
a : integer;   
s : string; 
begin 
readln (a);   
while a>=1 do   
begin     
if a mod 2 = 1 then     
s := s + '1'     
else       
s := s + '0';     
a := a div 2;   
end   
else  s := '0'; 
s := ReverseString (s); 
writeln (s); 
end.

(2.6k баллов)