помогите решить задачи 8 класс по информатике!решаются они через турбо Паскаль. 1)Найти...

0 голосов
30 просмотров

помогите решить задачи 8 класс по информатике!решаются они через турбо Паскаль.

1)Найти колличество нечетных делителей натурального числа,больших К(К вводятся с клавиатуры).

2)Найдите все натуральные числа х,у,z из интервала от 1 до 20,для которых выполняется равенство : ху(квадрат)=z(квадрат)

СРОЧНО НАДОО ПОМОГИТЕ!


Информатика (14 баллов) | 30 просмотров
Дан 1 ответ
0 голосов

var s:integer;
i,k:longint;
begin
readln(k);
i:=3;
while ii:=i+2;
if k div i=k/i then inc(s);
end;
writeln(s,' delitelei');
end.

 

var i,j:integer;

begin

for i:=1 to 20 do

for j:=1 to 20 do

if sqr(j)*i<20 then writeln('x=', i,' y=', j,' z=', sqr(j)*i);</p>

end.

(9.9k баллов)