Написать программу, которая по введенному значению аргумента вычисляет значение функции,...

0 голосов
296 просмотров

Написать программу, которая по введенному значению аргумента вычисляет значение функции, заданной в виде графика. Параметр R вводится с клавиатуры.


image

Информатика (37 баллов) | 296 просмотров
0

Не работает

0

Перед предпоследней строчкой поставь Write('X='); Read(X);

0

WriteLn('Y =', Y:6:3); а далее уже написано ReadLn; end.

Дан 1 ответ
0 голосов
Правильный ответ

Здесь небольшая проблемка: при больших R некоторых частей функций не будет видно...
Но тем не менее;


uses Crt;
var x, y, R: real;
begin

ClrScr;
Write(' X = ');  ReadLn(X);
Write(' R = ');  ReadLn(R);
if x<=-R then y:=-3  else<br>    if (x>=-R) and (x<=R) then y:=-sqrt(R*R-x*x) else<br>       if (x>R) and (x<6) then  y:=3+6*(x-6)/(R-6) else<br>          if (x>=6) then y:=(x-9);
ReadLn;
end.

Единственное, что осталось - распечатать значения Y...
Но по условию распечатка Y вроде не требуется...  Или я чего-то не понимаю...